Latest FAQs

Product FAQs

CentOS and Red Hat Release 7 Issues with Reality (Updated Jun'17)

CentOS/Red Hat release 7 introduced a number of issues causing problems with the installation of Reality. The Linux/AIX customisation facility has been extended to help resolve these issues.

Please see 'Linux/AIX customisation' in the Support/Component updates page. Of particular note are the 'System_Configuration' module which should be installed before attempting to install Reality and then the 'Customise_Reality' module which should be installed after Reality has been installed but before doing the build.

The following notes have been retained as a historical reference should issues continue after the customisation has been installed.


Until CentOS & Red Hat Release 7 becomes more stable it's advised to stay on Release 6 Versions. The below can, however, be used to load supported Reality onto a new installation of CentOS & Red Hat 7.

As there are command and library differences that affect products including Reality it is advisable to remain on CentOS & Red Hat Release 6 Versions, e.g. 6.5 and 6.7.

If you wish to load Reality under CentOS & Red Hat Release 7 you cannot upgrade from 6 Versions, you must start with a new install of 7.

Please follow the information below regarding how to load Reality…

Once CentOS or Red Hat 7 has been built with a clean install:

  1. Install Reality, refer to the Installation Guide for Unix, and then also load Unix-Connect, however, before building Reality you must exit setup.
     
  2. The file /usr/realman/15.1/files/build.conf then needs to be edited and the line
    CoraSysLibs="-lcurses -lcrypt -ldl -lpam"
    …   changed to…
    CoraSysLibs="-lcurses -lcrypt -ldl -lpam /lib64/libtinfo.so.5"
    This can be achieved on Centos 7 from the shell using
    sed -i 's@CoraSysLibs="-lcurses -lcrypt -ldl -lpam\"@CoraSysLibs="-lcurses -lcrypt -ldl -lpam /lib64/libtinfo.so.5"@g' /usr/realman/15.1/files/build.conf
  3. The Set up can then be resumed, continuing with the build Reality option.
     
  4. Then load the Latest Reality Service Pack for UNIX from the Latest Product Updates page.
      

Note:
The above is provided for user testing on CentOS & Red Hat Release 7 Versions, however, it's currently recommended to remain on Release 6 Versions until Release 7 is considered stable.

Also refer to FAQ Install/Update of Reality fails with build issues on LINUX/UNIX – Updated

Back to articles